Accounts e-mail HP

Attempting to change terrain values-- Freeciv crashes

Contribute and discuss maps, scenarios, rulesets or modpacks here.

Attempting to change terrain values-- Freeciv crashes

Postby Resodan » Sun Apr 24, 2011 6:03 pm

This kind of question had probably been answered several times, but I'm not sure how much the latest beta has changed things in terms of editing so I'll ask anyhow:

I've been trying to change the terrain.ruleset. All I've been doing is adjusting the numbers for certain values and occasionally changing what irrigation or mining does, etc.

When I do this and try to run Freeciv, the game doesn't load.
I tried doing the change to the 'Experimental' ruleset and the program loaded, but then failed to start start a game because it expected a certain value in the terrain ruleset.

So! Clearly I need to be careful about something. What do I need to be careful about?

Thanks!
Resodan
 

Attempting to change terrain values-- Freeciv crashes

Postby HanduMan » Mon Apr 25, 2011 1:41 am

If you start the server in a command prompt you'll get to see some messages telling what's wrong in your ruleset. You could also post your modified terrain.ruleset here so maybe someone could have a look at it.
HanduMan
 

Attempting to change terrain values-- Freeciv crashes

Postby Resodan » Wed Apr 27, 2011 12:03 pm

Hey HanduMan, thanks for your response! [img]images/smiles/icon_smile.gif[/img]

If set as the default ruleset, freeciv will not start as server or as client.

If set as the experimental ruleset, the client gives the message:

Could not load ruleset 'data/experimental/terrain.ruleset':
In secfile_from_input_file() [../../utility/registry.c:649]: secfile 'data/experimental/terrain.ruleset' in section 'terrain_forest': Expected value file "data/experimental/terrain.ruleset", line 387, poss 22
looking at: '1road_time =4'

I went through again and changed one or two values at a time, testing every ime I changed something and a few times some unexpected value kind of failure alert came up and I went through again-- can't say exactly what was wrong, maybe something with spacing.

I then transferred the experimental files to the default files and it works! [img]images/smiles/icon_smile.gif[/img]
Resodan
 


Return to Maps, rulesets and modpacks

Who is online

Users browsing this forum: No registered users and 5 guests