Accounts e-mail HP

Loading an existing game is very slow

You can get help here for any kind of problem ranging from Freeciv to the website.

Loading an existing game is very slow

Postby musketeer » Fri Feb 08, 2013 8:54 pm

Hi,

i like to play with a very big map and all nations (126). But the loading of an existing game is very slow. My computer is very fast (intel-2700 and 8 GB-Ram), but loading an existing game (after about 100 rounds) take sometimes 1-2 hours. Is there a way to load the game faster? Btw.: is there any multi core support? It seems freeciv is using only one core.

edit: My freeciv runs under Linux Ubuntu 12.10.
(Sorry for my bad english)
musketeer
 
Posts: 2
Joined: Fri Feb 08, 2013 8:44 pm

Re: Loading an existing game is very slow

Postby Davide » Sat Feb 09, 2013 1:42 am

I suspect this delay in loading a big save file is not caused by a hunger of computer resources but rather by a segfault in the freeciv server side which forces your client to repeatedly stop and restart the server, possibly hundreds of times before succeeding to load the file.

If you intend to investigate further, start your server by command line, load the savefile with the command "/load", and look for any "segfault" keyword. If you catch this happening, please report your log back here.
User avatar
Davide
 
Posts: 864
Joined: Sat Mar 24, 2012 12:34 am

Re: Loading an existing game is very slow

Postby musketeer » Sat Feb 09, 2013 1:32 pm

Thanks for your answer. hm, there were no segment fault or something else. After loading the AIs the server hangs 3 hours! All the time freeciv used a full core nearly to 100 % and about 2500 MBit. I guess here is a problem.
musketeer
 
Posts: 2
Joined: Fri Feb 08, 2013 8:44 pm


Return to General tech support

Who is online

Users browsing this forum: No registered users and 1 guest

cron