Accounts e-mail HP

Freeciv 2.2.2 Packages for Mac OS X

New releases, projects, multiplayer games, etc.

Freeciv 2.2.2 Packages for Mac OS X

Postby saltybanana » Sun Aug 01, 2010 8:27 am

Mac OS X packages for Freeciv 2.2.2 are now available [url=http://freeciv.wikia.com/wiki/Download#Mac_OS_X_Packages]here[/url].

In addition to using the 2.2.2 code base, my packages now install into the [b]/opt/com.bitaxis[/b]directory. This means that they no longer conflict with MacPorts. Behind-the-scenes sound support has been improved as well.

Here are some simple instructions:

  1. Download the appropriate .dmg file for your system (see below), and open it if your browser doesn't do it automatically
  2. Read the [b]~ Read Me First ~[/b]file
  3. If you are using the SDL package, skip this step. Otherwise, install X11 if necessary (see instructions for [url=http://8help.osu.edu/3670.html]Tiger[/url] & [url=http://8help.osu.edu/3688.html]Leopard[/url]).
  4. Run the installer
  5. Drag the Freeciv application into Applications or anywhere else you like
  6. Launch the Freeciv application

If you have Snow Leopard, you can try the Leopard (10.5) package to see if it works for you. I can't gurantee that it will, as I don't have a 10.6 system to test it on.

Enjoy!
saltybanana
 

Freeciv 2.2.2 Packages for Mac OS X

Postby devander » Wed Aug 11, 2010 10:05 am

Many thanks for these OSX builds. I tried them out on 10.6.4 and the SDL version works fine. Only sound is missing, the sound options are grayed out.

The X11 GTK version didn't work for me on 10.6.4, the app quits immediately after starting. I have Apple's X11 installed, the X11 info box says XQuartz 2.3.5 (xorg-server 1.4.2-apple53).
devander
 

Freeciv 2.2.2 Packages for Mac OS X

Postby saltybanana » Wed Aug 11, 2010 8:50 pm

Thanks for the feedback, devander.

The sound issue with the SDL package is a bit mystifying. I'll look into it. However, here is a workaround to enable sounds if you don't mind taking a quick trip through the Terminal:

  1. Install the SDL version.
  2. Launch Freeciv, then quit right away. You needn't start a game. This ensure the next step will work.
  3. Open the Terminal app, copy & paste in the command [b]open -e .freeciv-client-rc-2.2[/b]and press Enter. This should open the equivalent of the game client's preference file in TextEdit.
  4. Look for the line [b]default_sound_plugin_name="none"[/b]and change it to say [b]default_sound_plugin_name="sdl"[/b]instead.
  5. Save the file and quit TextEdit
  6. Launch Freeciv again and start a game. Sounds should be enabled from now on.

Now if you would indulge me a bit more, please try out the GTK package once more like so:

  1. Install the GTK package.
  2. Open the Terminal app, copy & paste in the command [b]export PATH=/opt/com.bitaxis/bin:${PATH} && freeciv-gtk[/b]and press Enter.
  3. Copy the next few lines from the Terminal's output and paste it into a reply message on this thread. Feel free to edit out bits like your username and such.

Hopefully this information will give me a better clue as to why the GTK client isn't working on Snow Leopard (I am still running Leopard).

In the meantime, I hope you enjoy the SDL version of Freeciv, with sounds even!

Regards...

devander"]Many thanks for these OSX builds. I tried them out on 10.6.4 and the SDL version works fine. Only sound is missing, the sound options are grayed out.

The X11 GTK version didn't work for me on 10.6.4, the app quits immediately after starting. I have Apple's X11 installed, the X11 info box says XQuartz 2.3.5 (xorg-server 1.4.2-apple53).[/quote]
saltybanana
 

Freeciv 2.2.2 Packages for Mac OS X

Postby devander » Fri Aug 13, 2010 12:14 pm

Thanks! the SDL sound works fine now after your suggested edit.

For the GTK package I followed your guidance and it turned out that freeciv-gtk2 didn't have the executable flag set after installation. After correcting that, the GTK version runs now too! These are the terminal commands:

> export PATH=/opt/com.bitaxis/bin:${PATH} && freeciv-gtk2
-bash: /opt/com.bitaxis/bin/freeciv-gtk2: Permission denied

> ls -l /opt/com.bitaxis/bin/
3680 -rwxr-xr-x 1 root admin 1,8M 1 aug 11:14 civmanual*
3328 -rw-rw-r-- 1 root admin 1,6M 1 aug 11:14 freeciv-gtk2
3608 -rwxr-xr-x 1 root admin 1,8M 1 aug 11:14 freeciv-server*

> sudo chmod 755 /opt/com.bitaxis/bin/freeciv-gtk2

And after that the GTK version worked.
devander
 

Freeciv 2.2.2 Packages for Mac OS X

Postby saltybanana » Fri Aug 13, 2010 9:30 pm

Looks like we independently found the problem & solution. Glad both are working for you.

Enjoy the game!

devander"]Thanks! the SDL sound works fine now after your suggested edit.

For the GTK package I followed your guidance and it turned out that freeciv-gtk2 didn't have the executable flag set after installation. After correcting that, the GTK version runs now too! These are the terminal commands:

> export PATH=/opt/com.bitaxis/bin:${PATH} && freeciv-gtk2
-bash: /opt/com.bitaxis/bin/freeciv-gtk2: Permission denied

> ls -l /opt/com.bitaxis/bin/
3680 -rwxr-xr-x 1 root admin 1,8M 1 aug 11:14 civmanual*
3328 -rw-rw-r-- 1 root admin 1,6M 1 aug 11:14 freeciv-gtk2
3608 -rwxr-xr-x 1 root admin 1,8M 1 aug 11:14 freeciv-server*

> sudo chmod 755 /opt/com.bitaxis/bin/freeciv-gtk2

And after that the GTK version worked.[/quote]
saltybanana
 


Return to Announcements

Who is online

Users browsing this forum: No registered users and 1 guest

cron